Project

General

Profile

Bug #8

create procedure and type space crashes hammer

Added by Wil van Antwerpen over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
Bug
Start date:
11/09/2014
Due date:
% Done:

0%

History

#1 Updated by Wil van Antwerpen over 5 years ago

  • Status changed from New to Closed

Summary
0000002: create procedure and type space crashes hammer
Description
When editing a pascal document and creating a new method the hammer crashes while typing
Steps To Reproduce
* Edit a .pas file
* Start on a new line and create a new procedure, for example "procedure test"
* on typing the space after typing "procedure" (without the quotes) the hammer will crash.

This one was addressed by disabling the parser for non DataFlex languages.
Nowadays Pascal is actually understood so would expect this to work OK.

#2 Updated by Wil van Antwerpen over 5 years ago

antwise

2015-10-23 13:04

administrator ~0000007
Unable to reproduce at the moment, I have also seen this happen for function.
IOW, need more steps.

antwise

2015-10-26 00:04

administrator ~0000008
Just reproduced in catpaw backuptarget by typing procedure above the tlistboxchange.

Error is in cParser.pkg, line 449

Function LineToItemEx Integer iForceType Integer iLn Returns Integer
    Local_Buffer sData pData tCElement_Size
    Integer iRet iItem iTmp
    String sTmp

---> Move (MKLineToElement(ppParseTask(Self),iForceType,iLn,pData)) To iRet

Stack is:
get_MKLineToElement
get_LineToItemEx
get_GetCurrentElement in cEditorEdit.pkg Line 1270
get_GetCurrentRefComplete in cEditorEdit.pkg Line 1295
msg_ShowLanguageList in cEditorEdit.pkg Line 1305
msg_OncmKeyUp in cEditorEdit.pkg line 3375

This can currently being prevented by not invoking the list by setting
- Hammer Options
- Show Codelist for "Procedures and functions" unchecked.

We probably want to augment ShowLanguageList to not trigger the parser for non DataFlex code.

Also available in: Atom PDF